PAYE bill has wrong Supplier

Problem reported by Adrian Bhagat 3 months ago

When I do Payroll and press ‘Import into Accounts’ to create bills, the bill for PAYE contributions has the supplier set to me instead of the HMRC. I have to go and edit it each time. I have checked the HMRC contact under Settings->Organisation->Details & Tax and that is correctly set to 'HMRC'. (This has been happening for a long time; I'm sorry I never got around to reporting it).

4 Replies

Hi Adrian,

To amend this, you must head to Payroll > Settings > Advanced > Select the supplier for PAYE.


Hi. Thanks for your reply. I don't see that settings. Under Advanced I only have a list of Payroll account codes.


Hi Adrian,

My apologies! You must head to Employers > Details > Select HMRC in the Payroll HMRC contact dropdown.

Found it. Thanks very much for your help.

Reply to this problem

Attach images by dragging and dropping or upload

Your comments will be public and can be answered by anyone in the Clear Books community.

Find out what we do and who we are